Answered By: Digital Library Services Team
Last Updated: Oct 03, 2016     Views: 27

BoB has the following information on their website:

"In order to use BoB you need to have a modern browser installed. We recommend

  • Internet Explorer 10 (or later)
  • Mozilla Firefox 44 (or later)
  • Safari 8 (or later)
  • Google Chrome 46 (or later)

Earlier versions of these browsers may work but are not supported."