Answered By: Digital Library Services Team
Last Updated: Nov 18, 2016     Views: 122

If you use an Manchester Metropolitan University on-campus PC to link to Scopus from the Library Services website and get a page saying:

"Scopus no longer supports Internet Explorer (IE7) or lower. To continue using Scopus, please upgrade your browser to IE8 or higher, or use Google Chrome or Firefox browsers." 

Click on the compatibility view button in the Internet Explorer address bar (screenshot below) and Scopus should open.

Screenshot of message users get when linking to Scopus via the internet explorer browser saying that in order to use scopus users should upgrade their browser as Scopus no longer supports internet explorer 7. Compatibility view button is highlighted.