Answered By: Digital Library Services Team
Last Updated: Sep 27, 2017     Views: 47

BoB has the following information on their website:

"In order to use BoB you need to have a modern browser installed. We recommend

  • Internet Explorer 11 (or later)
  • Edge 12 (or later)
  • Mozilla Firefox 44 (or later)
  • Safari 8 (or later)
  • Google Chrome 48 (or later)

Earlier versions of these browsers may work but are not supported."

Some outdated unsupported browsers, which may appear to work at first, but will invariably interrupt playback of BoB content after 9 seconds.